Foro de Quirinux

Avisos
Vaciar todo

Escaneres Cannon: incompatibles con Linux (Leer actualización 31-08-2021)


charliemartinez
(@admin)
Miembro Admin
Registrado: hace 2 años
Respuestas: 15
Topic starter  

Algo de información sobre los controladores:

Quirinux está basado en Debian. Quirinux trae más controladores preinstalados que los que vienen en Debian. En la mayoría de los casos, estos controladores son libres, aunque también los hay de código abierto y, en menor medida, privativos.

A veces, los fabricantes de hardware no desarrollan controladores para Linux ni ofrecen el código para que la comunidad pueda desarrollarlos.

Un usuario puede verificar si el hardware que va a adquirir es compatible con Linux. La cuestión se presenta cuando el fabricante afirma que sus dispositivos son compatibles pero "no en un 100%". El problema es que ese porcentaje de compatibilidad, podría resultar menor que el necesario para efectuar un uso apenas razonable.

ESCÁNERES COMPATIBLES CON QUIRINUX:

  • Quirinux funciona 100% con escáneres de la marca EPSON, con los que no requiere ningún tipo de configuración complementaria. Pueden ser utilizados, con solo enchufarlos, por todas las aplicaciones incluidas.
  • Los escáneres HP también son compatibles.

ESCÁNERES NO COMPATIBLES:

  • Algunos escáneres Canon NO son compatibles (ATENCIÓN VER ACTUALIZACIOŃ AL FINAL DEL ARTÍCULO).

Los controladores del aquellos escáneres Canon que indican que ofrecen "COMPATIBILIDAD PARCIAL" en verdad NO SON COMPATIBLES con Quirinux, ni con Debian, ni con Ubuntu, ni con ningún sistema basado en Linux.

¿Qué significa COMPATIBILIDAD PARCIAL?

Por compatibilidad completa nos referimos a la misma calidad de prestaciones que sus competidores y la posibilidad de ser utilizados por cualquier software incluido en Quirinux (Xsane, Gimp, Simple-Scan, etc) o en cualquier otra distribución de Linux.

La página oficial de Canon ofrece controladores y (al igual que EPSON) informa que Canon no da soporte técnico a problemas relacionados de LINUX. Pero, algo que también dice la página es que los controladores para Linux que ofrecen son "básicos" y "puede que no ofrezcan la misma funcionalidad".

COMPATIBILIDAD BÁSICA = NO COMPATIBILIDAD

En la práctica, si ponemos el ejemplo del escáner Pixma TR4550, de Canon, podemos decir que no sólo no ofrecen la misma funcionalidad sino que, prácticamente, no ofrecen ninguna. Si por "funcionalidad" entendemos que un escáner  nuevo debe, como mínimo, escanear con cierto nivel de calidad. Eso es imposible toda vez que el software para Linux que ellos ofrecen no permite seleccionar la calidad de salida, ofreciendo por defecto una verdaderamente baja, que ni siquiera específica (tenemos que acudir a otro software para ver que se trata de 150 pdi). Tampoco deja hacer recortes, ni escanear dibujos en serie o escanear en un formato que no sea pdf o jpg. Características básicas, ausentes por lo menos para ese modelo al día de la fecha en que estas palabras son escritas y ni hablemos de soporte OCR (reconocimiento de texto), algo un poco más complejo e igualmente imposible. ¿Modo línea? ¿Blanco y negro? ¡Nada! ¡Ni siquiera vista previa!

Por otra parte, ese software para Linux, el que ellos ofrecen, es publicitado como "controlador" cuando, en la práctica, no sólo no permite "controlar" los parámetros antes dichos, sino que -y esto es lo peor- no sirve para acceder al escaner mediante cualquiera de las demás aplicaciones que existen para el sistema.

Esto quiere decir que aquellos escáneres Canon que ofrecen "controladores básicos" para GNU/Linux SÓLO PUEDEN SER UTILIZADOS POR LA APLICACIOŃ QUE ELLOS DISTRIBUYEN, y no podemos usarlos con XSane, simple-scan, scanlite ni ninguna otra aplicación habitual del entorno porque NO SON COMPATIBLES con las mismas.

Nadie exige a Canon que mejore su software para Linux. Pero, si no van a colaborar con los desarrolladores de la comunidad del código abierto, deberían ser más claros a la hora de promocionar sus productos y no caer en lo que, consideramos, se trata de una publicidad engañosa, siendo benévolos en el término elegido. 

CONCLUSIONES:

El equipo de Quirinux considera que Canon debería ser más preciso y advertir a un posible comprador sobre aquellos casos en que sus escáneres, en Linux, no tienen controladores que puedan ser utilizados más que por una aplicación de ellos y deberían aclarar también cuando esa aplicación no permita modificar la resolución de escaneo.  Si la intención es desalentar al usuario de Linux, creemos que la idea de ofrecer un software de buena calidad para Windows y Mac y otra de mala calidad para Linux denota una falta de imaginación importante.  Sería mejor que no nos ofrecieran nada. El usuario de Linux no elije usar Windows luego de comprar un aparato que en la caja decía ser compatible pero no lo fue. El usuario de Linux devuelve el producto y luego escribe un artículo como este.

 

Charlie Martínez
Director de Quirinux

ACTUALIZACIÓN 31-08-2021

El usuario de Debian Juanjo Santamarta nos informa, en el grupo de Telegram de Debian en castellano, que el escáner Canon Lide 400 SÍ OFRECE FUNCIONALIDAD COMPLETA EN DEBIAN. Noticia que nos alegra. Esto significa, por supuesto, que este modelo también es compatible con Quirinux GNU/Linux y otras distribuciones basadas en Debian.

 

 

Este debate ha sido modificado el hace 2 años 7 veces por charliemartinez
Este debate ha sido modificado el hace 3 meses 4 veces por charliemartinez

Charlie Martínez
Desarrollador de Quirinux GNU/Linux.


Citar
Etiquetas del debate

Este sitio web utiliza cookies. Si continúas navegando es porque aceptas nuestra política de cookies y nuestra política de privacidad.- ACEPTAR

Aviso de cookies